3800Pro Forums banner
1 - 11 of 11 Posts

·
Registered
Joined
·
90 Posts
Discussion Starter · #1 · (Edited)
When i installed a S1X cam in my car i was told by the people from Intense to raise my shift point to 6300 rpm. So i sent my pcm in to DHP and had them do so. Now the car will run up to 6100 or so rpm and lay on its face till it shifts. When i first had the cam installed i was running 13.6 but prior to the cam install i was running 13.7 with 1.9 rocker arms. Now with the shift points raised i'm only running 14.4 to 14.0. I thought the car would run much better with this cam but i just haven't seen it yet. I have Intense push rods, comp cams lifters,105 springs and retainers, new timing chain with tensioner. Does any else with this cam run it up to 6300 with out problems?
 

·
Registered
Joined
·
565 Posts
What exactly does it do when you say it lays on its face? Does it hit a rev limiter? Does it feel like misfires?
 

·
Registered
Joined
·
90 Posts
Discussion Starter · #3 ·
It just kinda floats....it'll run up to 6000 or so then it doesn't seem to make any power. The car doesn't misfire or back fire like it's hitting the rev limiter it just doesn't go. It's like it's running out of it's power band then when it finally does shift into the next gear it'll pick up till that gear hits 6000 rpms or so.
 

·
Registered
Joined
·
59 Posts
Almost sounds like valve float, I had that problem after 6k with stock springs. Have you scanned you car yet to see if it's pulling timing, or if anything else it out of the ordinary after 6k?
 

·
Registered
Joined
·
90 Posts
Discussion Starter · #10 ·
"What valvesprings are you running?"
I installed the VSS-105 springs

"When this occurs, does your boost drop off?"
I have never looked at my boost gauge when this happens. I'll check it and let you know.
 
1 - 11 of 11 Posts
Top