3800Pro Forums banner
1 - 5 of 5 Posts

·
Registered
Joined
·
168 Posts
Discussion Starter · #1 ·
Alright well I got this 2.0 AFC and it kinda hit the crossover and melted the larger of the two plugs, I inspected the guts of the thing and what not and everything seems to be in good shape, would it be safe to say all I need is another plug or is the whole thing shot??
 

·
Registered
Joined
·
1,305 Posts
I would send it back to the manufacturer to have it checked out and fixed, Ken is pretty good about that kind of stuff. Though, I would mount it in the car to prevent any future damage. From experiance it seems like heat from the engine bay really shortens the life of those electronic "gizmos".
 

·
Registered
Joined
·
104 Posts
I agree with Lee, definitely doesn't like engine bay heat, it is a great piece, but myself and others have gone through one or so due to engine bay heat. I wired mine into the car and ever since I have never had a problem. (by the way in your monte if you dont have heated seats it fits great right behind the blank panel where your heated seat switch would normally be)
 

·
Registered
Joined
·
168 Posts
Discussion Starter · #4 ·
mcshocks said:
I agree with Lee, definitely doesn't like engine bay heat, it is a great piece, but myself and others have gone through one or so due to engine bay heat. I wired mine into the car and ever since I have never had a problem. (by the way in your monte if you dont have heated seats it fits great right behind the blank panel where your heated seat switch would normally be)
that would be a great idea for it, but I do have heated seats.
 
1 - 5 of 5 Posts
Top