3800Pro Forums banner
1 - 12 of 12 Posts

·
Registered
Joined
·
78 Posts
Discussion Starter · #1 ·
XP Cam, Comp 105#, Comp Titanium retainers, Comp Lifters, INTENSE LW Pushrods, PRJ Viton Valve seals...

#4, exhaust valve...The Comp valvespring snapped into 3 pieces tonight and took out the titanium retainers and valve seal. There is a nick on the top of the guide that would be covered by the valve seal. The valve moves up and down, seems a little tight, but I've never moved a valve up and down before... :confused:

What should I do?

Thanks...

Brad
 

·
Registered
Joined
·
78 Posts
Discussion Starter · #2 ·
When the spring broke, the valve dropped into the cylinder and chunked the piston as well as bent the valve. When the spring broke and threw off where the rocker hit, it took out the titanium retainer as well.

Only good part of this process was, I got to pull my first set of heads.

Give me advice, your thoughts, anything on what to do. I'm leaning towards that awful word of stock and it could be LS1 time again. Feel free to try and talk me out of it.

Otherwise, look for a pretty big sale of trans parts, valvetrain, cam, intercooler, exhaust, pcm, hp tuners, etc...soon.

Brad :(
 

·
Premium Member
Joined
·
2,450 Posts
That sucks. Not sure how you broke a spring. You're going to have to pull the engine, or at least the pan(which might be almost as much work as pulling the engine) to get the bad piston out. The guide might also be cracked if the valve hit the piston at an angle. I doubt the parts will be that much, even the machine work to fix the valve guide if required. You might even be able to buy replacement stuff from Ed Morad.
 

·
Registered
Joined
·
78 Posts
Discussion Starter · #4 ·
Thanks...I've been talking with Ed a few times this weekend, lol.
 

·
Registered
Joined
·
156 Posts
Sorry to hear that Brad, I hope all gets taken care of real soon. You know the right people to get things done that's for sure! ;)
 

·
Registered
Joined
·
347 Posts
Do you know what caused the spring to break up? How many miles did you have on them, I don't think I've ever heard of one breaking before.
 

·
Registered
Joined
·
78 Posts
Discussion Starter · #7 ·
The cam went in March of this year...so I'd say 9-10,000 miles.

I haven't heard of one breaking either...
 

·
Registered
Joined
·
18 Posts
Aren't most XP users running 105's?
Brad, sucks this happens to you man. Although we'd hate for you to leave the GP community, throwing a new stock block/blower in there and getting an LS1 car might not be that bad of an option. It's something I would consider if I were in your shoes. Then again, if your piston is fine then you could just put in a new valve/spring/retainer/seal and be good to go. Tough decision.
 

·
Registered
Joined
·
90 Posts
Aren't you suppose to fun the milled retainers with the XP cam on stock heads? I think they give an extra .030 of clearance.
 

·
Registered
Joined
·
78 Posts
Discussion Starter · #10 ·
I ran the viton valve seals to get my extra clearance. This was discussed before I put the cam in, I wanted to run the titanium retainers, and was told I could but had to use the vitons.

Thanks for the kind words Dave...I dont think you need to worry about the 105#s....a lot of people are running the same setup with the XP...seems I just got unlucky. :rolleyes:

Brad
 

·
Registered
Joined
·
90 Posts
OK i didn't know if you knew if you needed the extra clearance. Please disregaurd my reply on the national board also then. :eek:
 

·
Registered
Joined
·
32 Posts
Zooomer told me to use the modified retainer and not the valve seals to get my clearance :confused: . I hope I don't have a problem.
 
1 - 12 of 12 Posts
Top