3800Pro Forums banner

1 - 11 of 11 Posts

·
Registered
Joined
·
4 Posts
Discussion Starter #1
I have an 87 Fiero with a supercharged 3800. While driving today it just shut off. Was running terriffic.Like the ignition switch was turned off. Has spark and fuel pressure, but will not fire. Any ideas? Also, the temp gauge was never connected. Where is the temp sender on a 3800. any help would be appreciated. Lastly, any thoughts about bolting the coil pack to the bolt on top of the supercharger? Thanks again, Mike
 

·
Registered
Joined
·
312 Posts
hard to say ,may b crank sensor going out, you know how it is bad ground alot of things. just shut off is not alot to go on !!!
 

·
Registered
Joined
·
4 Posts
Discussion Starter #3
dead 3800 sc

I checked it out a bit more. No codes from the OBD. There is fuel. I opened a fuel line and turned it on. It seems like the injectors aren't firing. There is spark.
Any ideas? Thanks, Mike
 

·
Registered
Joined
·
3 Posts
re

hey im having the same problems and i have put 2 grand into the car to figure out wat is wrong with it.. im having the crank sensor replaced tommorow if that is the fix ill let you know.. crank sensor can and will mess with the timing and turning over of the motor on the 3800 series.. i will let you know. cause this **** is a bitch to figure out when it happens. and my car only has 40,000 miles on it..
 

·
Registered
Joined
·
3,187 Posts
get a pressure gauge on the fuel rail. Should read above 40. Also check your grounds
 

·
Registered
Joined
·
1,442 Posts
If it has spark, the crank sensor is OK. This crank sensor signal splits at the Ign. Module and then goes to the PCM for the injector pulse. I'd check for injector pulse, then check the module and PCM if you don't have an injector pulse.
 

·
Registered
Joined
·
297 Posts
Can't help on anything else, but the coolant temp sensor is located on the underside of the LIM below the thermostat housing.
 

·
Registered
Joined
·
3,187 Posts
It's not sensor related. The car will actually start no matter what's wrong with the sensors. It begins in primitive mode then looks for input from sensors to start it's routine. As this time start thinking as if you had a carbureted engine. Diagnose it as such.
 

·
Registered
Joined
·
3 Posts
re

i replaced the crank sensor and so far my car is running like a beuaty... will update in a few days.. it has yet to shut down.. try the crank sensor....
 

·
Registered
Joined
·
1,096 Posts
when i did my top swap i used a zzp pcm and it would not get injector pulse for the life of it then i did a security relearn and had it tuned (complete rewrite) and it worked so from my experience its the pcm
 
1 - 11 of 11 Posts
Top