3800Pro Forums banner
1 - 5 of 5 Posts

·
Registered
Joined
·
130 Posts
Discussion Starter · #1 ·
Ok guys, checked my ebrake and that's fine. However, I noticed that whenever I acclerate hard from a speed (usually 35mph or lower to chatch the good downshift, my brake light comes on. Once the car evens out, it seems to go off, but at the same time, sometimes it'll stay on longer than usual. Someone told me I could have low brake fluid, but it looks pretty good in the master cylinder. It's at least at the half-way line.

Someone also told me this is a common problem. Anyone think they can help?
 

·
Premium Member
Joined
·
2,450 Posts
Sounds like low brake fluid to me.
 

·
Registered
Joined
·
1,719 Posts
Sounds like low brake fluid to me too. I had that prob once also.

Or check the level sensor on the resevoir. I broke mine once changing plugs and didnt notice at first. It would wiggle around weird and the light would flash on and off whenever it felt like it.

Hope this helps,

Scott
 

·
Registered
Joined
·
1,224 Posts
Dan low brake fluid in resivour.

Luis Yes I would check your sensors. Each wheel has one. Do you have access to a Tech 2? If so that will be able to read your ABS code that you are probably throwing and that will help you find your posible bad sensor or loose wire. Only a Tech 2 though will read the code. Also you wount have an SES light either.
 
1 - 5 of 5 Posts
This is an older thread, you may not receive a response, and could be reviving an old thread. Please consider creating a new thread.
Top