3800Pro Forums banner

1 - 4 of 4 Posts

·
Registered
Joined
·
45 Posts
Discussion Starter · #1 ·
The volume pot on the stock stereo in my 98 Park Avenue Ultra is worn after 20+ years of use. What will happen is if you lightly touch it and it's in a bad mood or I drive over a bump, the volume will instantly go to max for a moment scaring the absolute crap out of me. The local stereo repair shop balled parked $150 to fix it, which I'm not going to do, so I'm going to just replace the whole unit with a salvage one off ebay.

I believe I have the 09356744 model number but I haven't yanked the unit out to confirm but I do know I have the blue connector where the wiring harness plugs in.

Does anyone happen to know how many different part numbers they used and what's the cross compatibility between them?
 

·
Registered
1998 GTP coupe. All stock and rust free. That will change soon.
Joined
·
86 Posts

·
Registered
Joined
·
45 Posts
Discussion Starter · #3 ·
Update time.

I found a salvage unit from a wrecked 2000 Park Avenue on Ebay, it got here yesterday and I put it in today and I have more problems than before.

It will turn on but the volume is really low and turning the volume knob manually has zero effect on it. Using the controls built into the steering wheel will make it go up and down but only for a second, the moment you let go of the button it goes back to where it was. I also tried playing a CD and it just spun for a little bit before not doing anything at all.

I don't know if I've missed something, I have an undiscovered issue that still needs to be addressed, or if this salvage unit is just junk.
 

·
Registered
Joined
·
5 Posts
Update time.

I found a salvage unit from a wrecked 2000 Park Avenue on Ebay, it got here yesterday and I put it in today and I have more problems than before.

It will turn on but the volume is really low and turning the volume knob manually has zero effect on it. Using the controls built into the steering wheel will make it go up and down but only for a second, the moment you let go of the button it goes back to where it was. I also tried playing a CD and it just spun for a little bit before not doing anything at all.

I don't know if I've missed something, I have an undiscovered issue that still needs to be addressed, or if this salvage unit is just junk.
Salvage units are hit and miss at the junk yards went thru 3 of them found one that works for the most part but tape player is iffy and cd player only plays pristine cds so i just put in a xm direct antenna adapter and thats all I use with the stock stereo is the xm radio
 
1 - 4 of 4 Posts
Top