3800Pro Forums banner

1 - 4 of 4 Posts

·
Premium Member
Joined
·
2,450 Posts
Discussion Starter #1
Welcome to my blog. I've put an XS1 cam, SLP headers, intake and cat back, a 3.3" pulley and ported supercharger on the car, along with mild ported heads and aftermarket single row timing chain. My LTFT's are a bit off on the rich side and I've discovered I've got huge part throttle knock at 1400-1600 RPM's, but only at cruise. The knock goes up to ~14 at times. As soon as I give it some gas, it degrades and goes away. I've got an HPtuner on the way and will attempt to find out why and how to fix it. My plan is to do a case learn first, in hopes that even without a SES, that may be the culprit. Next will be to put my old PCM back in, maybe I got a bad one and didn't know it? I've already checked to see if anything is hitting, and replaced my front motor mount to no avail, but it WAS bad anyway.
 

·
Premium Member
Joined
·
1,158 Posts
We've all started pretty much the same way Harry so don't feel alone on this tuning adventure. I have had my new plant in for 3 summers now and still dont have a final tune in it, although i'm getting closer (battling a fuelling issue).

I've learned a tonne with HPT and I KNOW you'll find it a wonderful tool once you get it.

LMK if you have any questions. I am by far no expert on any of this, but if I can help in any way i'll try. We have fairly similar mods. Close enough that what you described above i've lived through almost the exact same thing.

Ross.
 

·
Administrator
Joined
·
3,246 Posts
Harry, Try putting a larger pulley on the car to see if that part throttle KR goes away. It may be a fuel delivery problem at tip in or just a lean spot in the MAF table.
 

·
Premium Member
Joined
·
2,450 Posts
Discussion Starter #4 (Edited)
Did that. Got a 3.5" pulley on the car now, and it's the same. Plus, it only happens at cruise, steady throttle. If I nail the throttle, the knock goes away completely.
 
1 - 4 of 4 Posts
Top