3800Pro Forums banner
1 - 2 of 2 Posts

·
Registered
05 Pontiac Grand Prix 3.8 N/A
Joined
·
6 Posts
Discussion Starter · #1 ·
05 grand prix N/A 240,000 miles! head gasket went out about a thousand miles ago... Changed them out and car ran great on my 1hr 1/2 trip to and from work for a couple weeks ... Started it one morning to head to work and now it falls on its face when I touch the gas pedal.... Sometimes!!! other times it revs just fine then falls on its face again once you get near time for it to hit 2nd. Sometimes dies.... but not often! Just let off throttle for a few seconds and it revs or problems repeat! Misses at idle but no miss present under load! Only code I'm getting on my scanner is p0300! But shows misfire on 6 alot and 4 a little. Sprayed MAF with cleaner, Has new plugs/wires, MAP sensor, coils and ignition module replaced a few months ago! Checked for vacuum leaks with starting fluid and.... nothing! That I can tell anyway. I have a tech 2 scanner, although a cheaper one... Just don't have a clue what I'm looking at honestly! Scanner is a vident Ilink400. And I have a little mechanic background... But I'm hoping someone can help me narrow this problem down. Thankful for any help I can get.. a little cold to ride my motorcycle ... If I can help it!
 

·
Super Moderator
Joined
·
875 Posts
I'd do a compression check to see if your head gasket didn't wind up sealing properly. This appears to trace back to that work, and you'll probably have to dig back in to double-check things depending on what you find.
 
1 - 2 of 2 Posts
Top