3800Pro Forums banner
1 - 2 of 2 Posts

·
Registered
Joined
·
32 Posts
Discussion Starter · #1 ·
Have an 03 Impala LS 3800 @ 117K miles. In process of a L36-L26 upper swap and new gaskets for LIM/UIM. Have more planned on this. Just noticed a slow total coolant leak of 1/2 -3/4 gal over last few months, so go this going.

I cleaned up the LIM today and saw pitting around the coolant ports, same thing for the block off port but I'm not worried about that of course.

Would appreciate comment for those who have pulled LIM, compared to what you have seen on yours and if you think this is to excessive, I don't think so.

I included 2 pics of the pitting after cleaning, much more obvious in the dark and a bright light coming from the side, and 2 pics of failed gaskets around the water port, note 1 has a hunk of plastic missing, I'll be taking off my lower radiator hose from radiator and flushing engine out which I'd do anyway after I reassemble, but I guess it it has long been chomped up by water pump or stuck in radiator.

My UIM gaskets looked fine, actaully great, I was quite shocked, now melting or leakage around stove pipe. LIM gasket fine around the intake ports, just coolant failed.

thanks -D
 

Attachments

·
Registered
Joined
·
1,441 Posts
I've replaced at least 20 -25 of these 3800 intake gaskets. The metal erosion you have isn't enough to worry about. I've seen much worse. It's a good thing if you don't have any other corrosion, especially at the ports nearest the manifold corners. :)
 
1 - 2 of 2 Posts
Top