3800Pro Forums banner
1 - 16 of 16 Posts

·
Registered
Joined
·
168 Posts
Discussion Starter · #1 ·
Well I don't know what the problem is because I am really not keen on trannys, but I definately do have a problem. I have a 4T65e w/ about 88k miles on it. And lastnight on my way home, it felt different. I get out on the highway, start accelerating, it hits 3rd and just keeps climbing. Passes 6k(I have a DHP) and I am not even WOT(about 70%), and keeps going all the way to 6400 and hits the rev limiter(or valve float one of the two), and keeps bouncing, I had to let off the gas to 0% to get it to shift. Did this all the way home, I would slightly accelerate to pass, it would downshift as if I was hitting the throttle hard, stay in 3rd and wouldnt go into 4th without letting off the gas. I cycle through the gears manually and find that it won't downshift into 1st either. Anyone have any suggestions? Is a rebuild a remedy?? I can swap cams, heads, rockers, you name it engine wise. But when it comes to trannys I dont know my ass from a hole in the ground. HELP!! :( :confused:
 

·
Registered
Joined
·
467 Posts
Scan the computer for codes, sounds a lot like a TPS problem.
 

·
Registered
Joined
·
168 Posts
Discussion Starter · #3 ·
no codes tried that already.
 

·
Registered
Joined
·
116 Posts
Do a couples of miles with the car, mine only threw a code after a couple of days ...
 

·
Registered
Joined
·
467 Posts
If the problem is intermittant, it may not even set a code. Definately check your wiring though.
 

·
Registered
Joined
·
30 Posts
How is the fluid level? And what color is it? If its not setting a code, its probably not an electrical problem. It sounds like a bad seal on whatever applies the 3rd gear clutchs. Try switching the DHP like Intimd8r siad, and if nothing comes up it looks like you might be pulling your trans for a rebuild. :( Also pulling off the trans pan to see if there is any metal chunks, or parts of seals in the bottom of the pan or filter. Hope this helps.
 

·
Registered
Joined
·
168 Posts
Discussion Starter · #8 ·
alright well I topped off the fluid and it definately was not that. Let me try to explain it further. In 1st(manually) if I get to about the 3k mark and let off the gas the tranny goes into that sort of neutral state before it shifts and stays there like it wont let the gear slow me down, if I give it light throttle it will spin and maybe put 5hp to the ground, like it wont even maintain the speed I was going. Then if I give it a lil more throttle it will slam into gear. And up top in drive when I am at the end of third under normal throttle, it will not shift into 4th with out letting off the gas. Once I let off the gas, it will shift. But if I give it any throttle afterwards it will shift back into 3rd and continue.
 

·
Registered
Joined
·
19 Posts
Maybe this diagnostic chart can help....The definition sounds a little like the problem you're having.....Got it off the GM service site for techs.....You may never know, could be something simple we're not thinking of.....Good luck

No Engine Braking in Manual Second or Low Range

DEFINITION: A large engine RPM increase and forward vehicle speed decrease do not immediately occur when the transmission is shifted from third or fourth gear in Drive or Manual Third range to either first or second gear, Manual Second, or Low range.

POSSIBLE CAUSES

Accumulator and Manual 2-1 Band Servo Assembly
A loose or damaged manual 2-1 band servo oil pipe
Loose manual 2-1 band servo cover or accumulator cover bolts
A damaged accumulator cover spacer plate assembly
A damaged or missing servo piston seal or a servo piston cylinder O-ring seal
A missing servo exhaust screen assembly allowing debris into the cylinder
A misassembled manual 2-1 servo assembly
Manual 2-1 Band Assembly
A band assembly (680) that is worn or burned
A band assembly (680) that is disengaged from the anchor pin (102)
A band anchor pin (102) that is loose or missing
 

·
Registered
Joined
·
168 Posts
Discussion Starter · #10 ·
lol, that would be great if I knew what any of that crap means.
 

·
Registered
Joined
·
168 Posts
Discussion Starter · #13 ·
see thats the thing, I can get a complete rebuild kit for like 45 bucks with all the seals gaskets and clutches. But I dont know what I am doing for one, and for two I dont have the money to pay for someone to do it for me. I dont know how much it would be to rebuild an tranny with labor only, I can take it out and bring it to them and hand them a rebuild kit, but I dunno if that will cover everything yanno. And if I get one of those crooked biotches that like to try and take folks for their hard earned money telling me I need things I dont just to make up because I brought it in and have the kit and all he will be making is labor.
 

·
Registered
Joined
·
19 Posts
Typically, transmissions need speacial tools to disassemble and reassemble, such as clutch pack compressors and seal protector sleeves. I don't know if anyone would rebuild a tranny that was pulled by the owner and give a warranty, some techs do sidework if you bring them the tranny and parts, but they usually won't warranty anything if something happens. Also, the tranny tech may find hard parts that are needed, such as a valve body, sun gear, reaction sunshell, etc...
Wouldn't hurt to call around
 

·
Registered
Joined
·
168 Posts
Discussion Starter · #15 ·
Well I took it in for a diag run, and found out that third gear is just not cooperating. Needless to say either the sprag or some other miscellaneous trans part that has to do with the 2-3 gear is f'd up. It was just shifting straight from 2-4 all the time. No wonder I was gettin ****ty gas mileage. lol

BTW: When the guy test drove it he ran over a massive rock and split an entire rim in half What another great day I will post some pics to show here soon.
 

·
Registered
Joined
·
30 Posts
Wow your luck isn't going for you. I guess its time to pull the trans and see what broke or stripped. :(
 
1 - 16 of 16 Posts
Top