3800Pro Forums banner
1 - 5 of 5 Posts

·
Registered
Joined
·
66 Posts
Discussion Starter · #1 ·
Okay, I dont really know where the problem is, so I cant really categorize it.

RPM's drop when the car is idle in D when at a stop. If I turn the wheel while stopped, it drops even more, getting close to a stall. NO codes, nothing abnormal on the scan. The problem gets worse if I have extra load on the electrical system (rear defog, heater)

First thing I thought was maybe alternator???? Any help would be greatly appreciated.
 

·
Premium Member
Joined
·
2,450 Posts
I'd suggest looking at your TPS and check for vacuum leaks, although, a vacuum should cause the idle to be higher. IAC could be a problem too. Have you scanned? Check what your TPS voltage is at idle.
 

·
Registered
Joined
·
72 Posts
I'm not sure what would cause it to almost die on you, but it's understandable that turning the wheel or putting a higher electrical load would make it worse. Turning would create more of a load with the PS pump and the added electrical load would take more engine power to turn the alternator. Voltage will drop if the RPMs drop too low. That causes the alternator to stop charging. You can check voltage to see if the alternator is charging the whole time. Maybe someone else can offer some further input.
 

·
Registered
Joined
·
44 Posts
Turning would create more of a load with the PS pump
This happens in my Regal. Im pretty sure it is normal, although it shouldnt be near stalling. idle should be around 750.. when I turn my wheel it goes down to ~500, but only for a second or two.
 

·
Registered
Joined
·
168 Posts
mine does that but I have a cam, unless you have a cam and a rough idle this shouldnt be happening, did you remove your TB screen?
 
1 - 5 of 5 Posts
Top