3800Pro Forums banner
1 - 13 of 13 Posts

·
Registered
Joined
·
19 Posts
Discussion Starter · #1 ·
When taking off slowly, stopping, or turning the wheel it feels like something is loose in my front suspension (I can feel it through the steering wheel). It's not the steering wheel that's loose as I've already checked that. It kinda feels like when I'm taking off something will shift a few centemeters down in the front suspension somewhere, same thing when I stop but in the other direction. When I turn the wheel it just feels like a couple knocks.... it feels like all this is in the suspension and the knocking is coming up through the wheel to my hands for me to feel it. Any ideas what I'm dealing with here? Only thing I've changed has been my sway bars/bushings.... Thanks
 

·
Registered
Joined
·
14 Posts
couple thigs to check for.

Bad wheel hub. with the tire off try and move the disc brake up and down..if it does this is due to a bad hub.

bad ball joints.. with the wehll off try and move the disc brake left to right if it moves the bal joint is bad.

how many miles on your end link bushings and sway bar bushings? Have you checked them for wear?

also make sure your stru tower bolts are tight. also check the strut location up top and see how the bushing if it is worn this could be causing the sound you are describing.
 

·
Registered
Joined
·
19 Posts
Discussion Starter · #3 ·
I have about 42,000 miles on the car.... my front swaybar endlink bushings seem to be worn pretty bad... Do you really think that could have this effect? I have BMR front and rear sway bars with poly bushings.... but on the front you reuse the stock bushings on the endlinks on top and bottom... the top ones are worn.
 

·
Registered
Joined
·
31 Posts
I had something similar, and it turned out to be my strut bearings...

I suppose just run down the list of things that could be loose/worn....

-tie rods
-ball joints
-wheel hubs....etc...

Good luck!
 

·
Registered
Joined
·
168 Posts
strut bearings??
 

·
Registered
Joined
·
19 Posts
Discussion Starter · #6 ·
I've been suggested a lot of things....

One thing I can see that is worn are my front sway bar end link bushings. I have poly bushings in the middle and stock rubber on the top and bottom. The top ones are worn pretty good. I don't see how this could be causing the problem though...
 

·
Registered
Joined
·
30 Posts
Try the 18mm sub-frame bolts, control arm bushings, and make sure the sway bar bushings are greased.
 

·
Registered
Joined
·
45 Posts
Mine did that when it was new so I took it to my dealer and they fixed it since it was a deffective "steering intermediate shaft" Poor design as they put it.
 

·
Registered
Joined
·
46 Posts
I was told its that intermediate shaft, and that they can "inject" grease into it to fix it, I havent investigated it further though, but it is becoming annoying
 

·
Registered
Joined
·
1,097 Posts
I had a bad strut mount.....$35 part and an easy swap if your car is lowered. If not then you will need a spring compressor. Tie-rod is about $30. I just changed mine with a buddy. I was so easy, you wont believe that something steering related will only take a few mins. to replace.
 

·
Registered
Joined
·
230 Posts
BlownP, How did you know that you had a bad strut mount...I too have something that feels loose in the front suspension, but can't figure out what it is, and I am trying to narrow my options down. The car does have about 80K miles on it, so maybe things just need to be refreshed or something...?
 

·
Registered
Joined
·
1,097 Posts
When ever I would make sharp turns in drive way's etc. I would notice a clunking noise. This happens since the spring can't turn smoothly and the bearing it runs on binds a bit. The part in relativly in-expensive and a pretty easy install
 
1 - 13 of 13 Posts
Top