3800Pro Forums banner
1 - 5 of 5 Posts

·
Registered
Joined
·
9 Posts
Discussion Starter · #1 ·
Does anyone know the exact fuse/relay that needs to be replaced to get the Fan to work on 1,2? Right now I am running them on 3,4,5 because 1,2 dont work anymore.

I think it is the blow relay... but I am not sure due to the vagueness of the users manual.

Thanks
 

·
Premium Member
Joined
·
2,450 Posts
Well, you don't indicate what car you have, but I'll give it a shot. I'd say your blower motor resistor pack is bad. Only high uses a relay. One fuse for high and one for all the other speeds.
 

·
Registered
Joined
·
9 Posts
Discussion Starter · #4 ·
I dont know what I was thinking.... Sorry, I have a 2002 GTP. The blower resistor pack... is this expensive to replace or can I just go into a parts store and pick it up? Where does this have to be changed at?

As you can tell... I am not very knowledgable yet with this stuff. :eek:
 

·
Registered
Joined
·
13 Posts
You need a new blower resistor. It costs about $30, IIRC, and includes the resistor circuits (which are non-servicable, unfortunately) for speeds 1 - 4 and the relay for speed 5. This is a dealer-only part. I found that GMPartsDirect had a better deal, even when shipping was included. On my '00 Monte Carlo, it's up underneath the passenger's side kickplate, between the blower motor and the firewall and is a ROYAL PITA to remove due to the fact that it's right up against the firewall and because of the bad working position.

To remove it, remove the lower kick plate on the passenger's side and disconnect the resistor from the wiring harness, then remove the one screw on the side facing you and loosen the two screws on the firewall side. It should pull right out.

This is all assuming that your GP is similar to my Monte Carlo. Hopefully someone else will chime in if that's not the case.
 
1 - 5 of 5 Posts
Top