3800Pro Forums banner

1 - 7 of 7 Posts

·
Registered
Joined
·
2 Posts
Discussion Starter · #1 ·
As I am doing my lower intake and valve cover gaskets right now, I was having boost issues before with only getting around 4-5 psi at WOT. I have checked for belt slip, BBV seems to work but actuator move half way not touching housing, checked all the vacuum lines no cracks, not sure about if its a coupler, solenoid, MAF, MAP, 02 sensor or what. Wondering where to go from here. I ordered a coupler and my whole top end is off as of right now so any help or considerations would be appreciated.

-Nick
 

·
Registered
Joined
·
1,151 Posts
when the cars off is the little arm touching the stop? try loosening the bolts and pushing the BBV all the way down. Also check all the vacuum lines for a tight fit on the nipples. If they pull off easily just put a small zip tie on them to hold it in place.
 

·
Registered
Joined
·
66 Posts
i was running my buddys evo on the highway and the car all the sudden wouldnt full throttle shift the next time i started it/ then would read low engine power and shut off took it to the dealer . took them 4hrs to find out it had popped a vacum line off now cars really laggy until high rpm goes from like 5psi to 9.5by redline so might be vacum line? or wore of supercharger?
 

·
Registered
Joined
·
3,185 Posts
9.5psi means you have an internal issue. Usually the LIM gasket, head gasket or exhaust manifold gasket are causing blockage and a boost stacking situation. What size pulley?
 

·
Registered
Joined
·
1,594 Posts
i was running my buddys evo on the highway
9.5psi means you have an internal issue. Usually the LIM gasket, head gasket or exhaust manifold gasket are causing blockage and a boost stacking situation. What size pulley?
imp0ster that would be an EVO not a 3800
Since we are off topic how about my 47.5 psi?
 

·
Registered
Joined
·
66 Posts
stock 3.8in pulley size ive been running like this for 40k+ miles no issues but my car is oddly quick from 70 mph and more lilke i pull my buddies intake tune dp sti that traps 106mph/ I just have intake 3in catless dp and zzp reflash my car was trapping 96mph stock and now 99 after intake dp and tune and running low 14's on bald street tires factory freak?
 

·
Registered
Joined
·
2 Posts
Discussion Starter · #7 ·
would a leaking LIM gasket be a potential cause? It happened during the late summer where it would feel like a large loss of power and then it would all the sudden kick back in sometimes. After about October, it has been consistently at 4-5 psi on a 3.4 pulley setup which i used to get double that. Would like some more insight as I've checked all vacuum lines and were fine.
 
1 - 7 of 7 Posts
Top