3800Pro Forums banner

1 - 2 of 2 Posts

·
Registered
Joined
·
1 Posts
Discussion Starter #1 (Edited)
Checked common issues Regal GS not charging, now won't turn over

Hello, I am new to this forum and need help. Sorry in advance for the long post. I went through the over posts to see if they could help but I'm stumped. I have replaced the battery, alternator, and starter. Checked the fusible links and fuses, all good. Grounds are good and see no corrosion in any of the wires. No security light on. Used to run fine, just couldn't charge. I could tell how bad it was by the rpm gauge. It would jump around, just the gauge, not the engine, and when it jumped to the end, it would die. Today, I charged the battery to drive it to the mechanic to get it checked out, but it won't start. Its making one click, and thats it. Also, when I turn the key to on, it doesn't make any of the noises it used to, ex the seat belt not being on noise, and it doesn't auto lock the doors when it would drive and wouldn't auto unlock the door when I turned the car off. Also, every now and then I heard a wierd buzzing sound from the passenger side but driving wasn't effected during it. What am I overlooking? I really dont want to pay to have it towed if either problem is an easy fix.
 

·
Registered
Joined
·
1,099 Posts
1- Take the grounds aparts and clean the sub frame area as well. You may even have to look at the grounds inside the vehicle behind the dash. Make certain they are very tight.
2- Try out a known good battery. Make certain you have 13.3 volts

Always make absolute certain your grounds and power REALLY are good.

Start with the basics first.

( the old infamous trio of the 70's=Battery, Starter, Alternator= all 3 lked to fail within a short time together)..best of luck
 
1 - 2 of 2 Posts
Top