3800Pro Forums banner
1 - 4 of 4 Posts

·
Registered
Joined
·
5 Posts
Discussion Starter · #1 ·
Hi

I bought a 97 firebird 3800 that sat for 3 years. It wasn't running when i bought it, but now I got it to run.

The problem is, that the car is obviously misfiring. Sounds like maybe one or two cylinders. However there is no code.
I have replaced coils, spark plugs, and wires with no luck.
Any help is greatly appreciated.
 

·
Administrator
Joined
·
1,318 Posts
Possibly a crank or cam sensor, vacuum leak, maf/map/O2 sensor issue... It'd be good to scan with an OBD2 data logger like a Bluetooth ELM to watch data live on your phone.
 

·
Registered
Joined
·
5 Posts
Discussion Starter · #3 ·
Possibly a crank or cam sensor, vacuum leak, maf/map/O2 sensor issue... It'd be good to scan with an OBD2 data logger like a Bluetooth ELM to watch data live on your phone.
I have replaced the MAF and TPS, after that there have been zero codes. Is it possible to crank, cam sensors are bad without throwing a code? There are no vacuum leaks.
 

·
Administrator
Joined
·
1,318 Posts
Engines don't throw codes for many issues that you will notice as obvious deviations from normal running. The codes also don't point directly to the problem many times. They only set a light if specific readings are made/missed that the computer is set to look for, which is not an all-encompassing set of problems.

Try not to get too certain about something "not" being the problem while going thru the troubleshooting process. You will go over various parts/potential issues and move on, but never let yourself get overconfident that you've ruled things out. Until the car's back to 100%, anticipate that you may have to double back and evaluate things again or in a different way.
 
1 - 4 of 4 Posts
Top