3800Pro Forums banner

1 - 3 of 3 Posts

·
Registered
Joined
·
2 Posts
Discussion Starter #1 (Edited)
Hi guys,
I have been working on tuning my 2005 Monte Carlo SS with HPTuners over the last few months. I finally got everything dialed in with my wideband and started working on timing adjustments. The problem I ran into was, I have to drop down to 8-9° at fully WOT in order to not see any KR. The car is running 15.5s quarters as well, and feels sluggish. Otherwise, it seems to run fine though, no chugging or misfires or anything. The mods it has on it are
  • CAI
  • 180t stat
  • ZZP Headers and 3" DP
  • Autolite copper 104s
  • 3.4" Pulley
  • Northstar throttle body kit from ZZP
  • Ported blower housing from ZZP
  • 1.9:1 rockers
The exhaust from the 3" downpipe is all custom 2.5" with a 24" louvered core glasspack as a resonator and two 12" glasspacks as mufflers. The car seemed to have increased knock when I had the 24" glasspack put in (I had a 18" louvered in before it), but I don't really see how a slightly longer glasspack would suddenly make the car knock and restrict flow a bunch. The car is making about 10.5psi of boost according to the MAP sensor, and my AFR starts at 12.5 and ends the pull at 11.6. I attached my tune as well as a scan.

Anyone have some ideas?

Edit: File extension isn't allowed so I uploaded them here tune
 

·
Super Moderator
Joined
·
375 Posts
Don't know where the files are, but you may need to clean your MAF sensor with some CRC QD Electronics or MAF cleaner (same general stuff). My old g/f had that much KR in her car with similar setup, due to over-applying K&N oil that was drawn into the MAF. Easy 30sec fix under $10, if that's the case... otherwise, good little upkeep anyway.

If you want, you can email the files (I have DHP, so I'd need the .bin tune file version). Same name @ gmail.
 

·
Registered
Joined
·
2 Posts
Discussion Starter #3
Don't know where the files are, but you may need to clean your MAF sensor with some CRC QD Electronics or MAF cleaner (same general stuff). My old g/f had that much KR in her car with similar setup, due to over-applying K&N oil that was drawn into the MAF. Easy 30sec fix under $10, if that's the case... otherwise, good little upkeep anyway.

If you want, you can email the files (I have DHP, so I'd need the .bin tune file version). Same name @ gmail.
I can try cleaning it, I got it less than a year ago from ZZP, although I believe those are used ones off LQ4s. As for the files, I thought I had uploaded them, but apparently the HPTuners files aren't allowed extensions and I can't upload a .zip file either.
 
1 - 3 of 3 Posts
Top