3800Pro Forums banner

1 - 1 of 1 Posts

·
Registered
Joined
·
39 Posts
Discussion Starter #1
Hey all, it's been a long time since I've posted here, but the 3800s never left our family! I no longer have my Riv, but my mother and brother each have '04 GPGTs and my mother in law has an 05 LeSabre, and I still love working on the 3800s.

I'm calling out for help on a serious issue we've been having in my mother's '04 GP. Intermittently the fuel pump stops running, sometimes at start, sometimes while driving (!). It may be a few days between failures, may be a few hours, may be a few weeks. It seems to be more pronounced now that it's hot. I'll give a rundown of all the troubleshooting we have done.

1) found that the pigtail at the fuel pump itself was loose, and the pump noisy. Replaced pump, replaced wiring pigtail (the plug and wires came with the new pump!). At the time I thought it would be neat for testing, so I wired a 194 bulb socket to the fuel pump wire and fed it up into the trunk. Turns out this is the best thing since sliced bread, because the problem was not solved. The fuel pump is a lot quieter now though.

2) when the car dies, we know the fuel pump isn't running because the light doesn't come on. Light on = fuel pump on. When we are having issues I slide the light through the back seat so we can see if from inside the car.

3) when the fuel pump won't turn on, removing and reinstalling the FP relay "fixes" the problem for a while. We tried swapping with other relays in the box and the problem is the same - intermittent and somewhat unpredictable. Wiggling/removing the relay fixes it.

4) I thought the relay was pretty loose in it's socket, so initially I messed around with bending pins on the relay, I tried building the pins thicker with a little solder, a couple different things. Finally I called up Morad and got a replacement for the underhood fuse box. I used a different relay (not the one I bent pins and built up with solder) and the problem is the same. Wiggling/removing the relay fixes it.

5) I bought a brand new relay. Still fits nice and tight in the fusebox. Problem is the same.

6) Took out the fuse box and checked wiring harnesses with an ohmmeter. The trigger from the ECU (green wire w white stripe I think) is good, feed to the pump (grey wire w red stripe I think?) is good. Loose or brittle wires don't explain to me why wiggling the relay is the fix anyway.

7) swapped PCMs, reflashed w old PCM program and VIN. Problem is the same. Wiggling the relay fixes it.

What am I missing here? I've tested and replaced every part I can think of. I suppose I could try replacing wiring harnesses completely, but this really, really doesn't seem like the issue, nor does it explain why wiggling the relay makes it work again.

Any advice?
Thanks
 
1 - 1 of 1 Posts
Top