3800Pro Forums banner
1 - 2 of 2 Posts

·
Registered
Joined
·
19 Posts
Discussion Starter · #1 ·
My '04 Regal has ~125k and was bought from the 2nd owner and is a very nice car which I plan on keeping. In the past 6 months the car shut off while driving 3 or 4 times, each time while I was going slow. All the lights on the dashboard lit up but if I shifted to neutral it started right up again. It seemed to be happening in very humid weather when I used the AC to defog the windshield.

About a week ago it shut off again in the exact same place on the exact same road while making a right turn. It then hit occurred to me that I had signaled for a right turn both times when the car immediately shut off. I pulled into a parking lot and was able to shut the engine off 3 times in a row by using the turn signal lever to indicate a right turn. It seemed to be only a right turn but after many tries driving around in the empty lot it shut the car off many times using the blinker for a left AND a right turn.

Once again, when the engine shuts off all of the dash lights come on similar to when the key is first turned to 'ON' before proceeding to 'START'.

My only thought is the turn signal stalk/ switch is worn and somehow shorting to ground although I don't see how it could ground out the coil and shut down the engine.

My plan is to pay the dealer to replace the turn signal assembly and while they're at it, the ignition switch also. Electrical problems are a nightmare and I don't want to mess with the steering wheel and airbag removal, etc.

Any suggestions would be appreciated in that I really shouldn't be driving the car without turn signals.

Thanks, Mark
 

·
Registered
Joined
·
15 Posts
Inspect your wire harness under the hood for any damage. I had issues where the car shut off. Once it was the harness to the cam sensor was damaged by contacting the crank pulley. And once I had wires in the back touching the headers.
 
1 - 2 of 2 Posts
Top